Configuration Cisco Vlan | Command line | My Experience

Cisco Switch Vlan:

Creating Vlan on Cisco Switch

config>vlan 10

config>name dataH

config>interface range fastethernet f0/1-12

config(if-range)>switchport mode access

config(if-range)#switchport access vlan 10

config(if-rang)#no shutdown

Trunk Vlan on Cisco switch

config>#interface FastEthernet0/1

config<>switchport trunk encapsultion dot1q

config>#switchport mode trunk

config>#switchport trunk allowed vlan 1-50

Router configuration Vlan

config>Interface fastethernet 0/0

configNo shutdown

config>interface fastethernet 0/0. 10

configencapsulation dot1Q 10

configip address 192.168.10.1 255.255.255.0

config>end

VOICE Vlan and Creating dhcp pool for Voip device

config>vlan 20

config>name voiceH

config>interface FastEthernet0/2

configswitchport mode access

configswitchport voice vlan 20

configno shutdown

config>end

config>ip dhcp pool voip

config>network 192.168.20.0 255.255.255.0

config> default-router 192.168.20.1

config>option 150 ip 192.168.20.1

Config>dns-server 213.42.20.20

Config>exit

Reserved IP Address on DHCP Pool

Config)ip dhcp excluded-address 192.168.20.1 192.168.20.10

Locate External DHCP server

Config)ip helper-address 192.168.10.1 remote dhcp server

Enable Telnet on Cisco Switch

Config) line vty 0 5

Config-line) password cisco

Config-line) login

Config)exit

Two Switches communicate same VLAN- Using VTP Protocol

main swith

config>vtp version 2

config>vtp domain sukhesh.com

config>no ip domain-lookup

config>interface range fa0/1 – 4

config-if-range>switchport trunk encapsulation dot1q

config-if-range>swithport mode trunk

exit

config>spanning-tree mode rapid-pvst

config>vlan 10

config-vlan>name data10

exit

config>interface vlan 10

config-if>ip address 172.16.118.1 255.255.255.0

exit

config>ip dhcp pool data10

config-dhcp>network 172.16.118.1 255.255.255.0 default router

config-dhcp>172.16.118.1 dns-server 172.16.200.247

exit

Second Switch

config>vtp mode client

config>no ip domain-lookup

config>interface range fa0/1 – 4

config-if-range>switchmode mode trunk

exit

config>interface range fa0/6 – 7

config-if-range>switchport access vlan 10

exit